Type to search.

Sysmon for Linux Integration

Serverless Observability

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Serverless Security

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Stack 9.0+

The Elastic Stack includes Elastic's core products such as Elasticsearch, Kibana, Logstash, and Beats.

Availability

  • Generally available since 9.0

    This functionality is generally available and ready for production usage.

Unless stated otherwise on the page, this functionality is available when your Elastic Stack is deployed on Elastic Cloud Hosted, Elastic Cloud Enterprise, Elastic Cloud on Kubernetes, and self-managed environments.

This documentation corresponds to the latest patch available for each minor version. If you're not using the latest patch, check the release notes for changes.

Version 1.9.1 (View all)
Subscription level
What's this?
Basic
Developed by
What's this?
Elastic
Ingestion method(s) File
Minimum Kibana version(s) 9.0.0
8.11.0

The Sysmon for Linux integration allows you to monitor the Sysmon for Linux, which is an open-source system monitor tool developed to collect security events from Linux environments.

Use the Sysmon for Linux integration to collect logs from linux machine which has sysmon tool running. Then visualize that data in Kibana, create alerts to notify you if something goes wrong, and reference data when troubleshooting an issue.

Note

To collect Sysmon events from Windows event log, use Windows sysmon_operational data stream instead.

You need Elasticsearch for storing and searching your data and Kibana for visualizing and managing it. You can use our hosted Elasticsearch Service on Elastic Cloud, which is recommended, or self-manage the Elastic Stack on your own hardware.

For step-by-step instructions on how to set up an integration, see the Getting started guide.

The Sysmon for Linux log data stream provides events from logs produced by Sysmon tool running on Linux machine.

Example
JSON
{
    "@timestamp": "2025-10-24T17:05:31.000Z",
    "agent": {
        "ephemeral_id": "c3528964-47f7-4a97-968f-b24d27fb3f5e",
        "id": "95b30c83-143a-4fd0-bbe5-4764610ade5c",
        "name": "elastic-agent-46474",
        "type": "filebeat",
        "version": "8.17.3"
    },
    "data_stream": {
        "dataset": "sysmon_linux.log",
        "namespace": "83328",
        "type": "logs"
    },
    "ecs": {
        "version": "8.17.0"
    },
    "elastic_agent": {
        "id": "95b30c83-143a-4fd0-bbe5-4764610ade5c",
        "snapshot": false,
        "version": "8.17.3"
    },
    "event": {
        "action": "log",
        "agent_id_status": "verified",
        "dataset": "sysmon_linux.log",
        "ingested": "2025-03-13T12:29:35Z",
        "kind": "event",
        "timezone": "+00:00"
    },
    "host": {
        "architecture": "x86_64",
        "containerized": true,
        "hostname": "elastic-agent-46474",
        "ip": [
            "172.20.0.2",
            "172.18.0.7"
        ],
        "mac": [
            "02-42-AC-12-00-07",
            "02-42-AC-14-00-02"
        ],
        "name": "elastic-agent-46474",
        "os": {
            "kernel": "5.15.153.1-microsoft-standard-WSL2",
            "name": "Wolfi",
            "platform": "wolfi",
            "type": "linux",
            "version": "20230201"
        }
    },
    "input": {
        "type": "filestream"
    },
    "log": {
        "file": {
            "device_id": "2080",
            "inode": "1097862",
            "path": "/tmp/service_logs/sysmon.log"
        },
        "offset": 0
    },
    "message": "Sysmon v1.0.0 - Monitors system events",
    "process": {
        "name": "sysmon",
        "pid": 3041
    }
}
Exported fields
Field Description Type
@timestamp Event timestamp. date
cloud.account.id The cloud account or organization id used to identify different entities in a multi-tenant environment. Examples: AWS account id, Google Cloud ORG Id, or other unique identifier. keyword
cloud.availability_zone Availability zone in which this host is running. keyword
cloud.image.id Image ID for the cloud instance. keyword
cloud.instance.id Instance ID of the host machine. keyword
cloud.instance.name Instance name of the host machine. keyword
cloud.machine.type Machine type of the host machine. keyword
cloud.project.id Name of the project in Google Cloud. keyword
cloud.provider Name of the cloud provider. Example values are aws, azure, gcp, or digitalocean. keyword
cloud.region Region in which this host is running. keyword
container.id Unique container id. keyword
container.image.name Name of the image the container was built on. keyword
container.labels Image labels. object
container.name Container name. keyword
data_stream.dataset Data stream dataset name. constant_keyword
data_stream.namespace Data stream namespace. constant_keyword
data_stream.type Data stream type. constant_keyword
dataset.name Dataset name. constant_keyword
dataset.namespace Dataset namespace. constant_keyword
dataset.type Dataset type. constant_keyword
destination.domain The domain name of the destination system. This value may be a host name, a fully qualified domain name, or another host naming format. The value may derive from the original event or be added from enrichment. keyword
destination.ip IP address of the destination (IPv4 or IPv6). ip
destination.port Port of the destination. long
dns.answers An array containing an object for each answer section returned by the server. The main keys that should be present in these objects are defined by ECS. Records that have more information may contain more keys than what ECS defines. Not all DNS data sources give all details about DNS answers. At minimum, answer objects must contain the data key. If more information is available, map as much of it to ECS as possible, and add any additional fields to the answer objects as custom fields. group
dns.answers.class The class of DNS data contained in this resource record. keyword
dns.answers.data The data describing the resource. The meaning of this data depends on the type and class of the resource record. keyword
dns.answers.name The domain name to which this resource record pertains. If a chain of CNAME is being resolved, each answer's name should be the one that corresponds with the answer's data. It should not simply be the original question.name repeated. keyword
dns.answers.ttl The time interval in seconds that this resource record may be cached before it should be discarded. Zero values mean that the data should not be cached. long
dns.answers.type The type of data contained in this resource record. keyword
dns.header_flags Array of 2 letter DNS header flags. keyword
dns.id The DNS packet identifier assigned by the program that generated the query. The identifier is copied to the response. keyword
dns.op_code The DNS operation code that specifies the kind of query in the message. This value is set by the originator of a query and copied into the response. keyword
dns.question.class The class of records being queried. keyword
dns.question.name The name being queried. If the name field contains non-printable characters (below 32 or above 126), those characters should be represented as escaped base 10 integers (\DDD). Back slashes and quotes should be escaped. Tabs, carriage returns, and line feeds should be converted to \t, \r, and \n respectively. keyword
dns.question.registered_domain The highest registered domain, stripped of the subdomain. For example, the registered domain for "foo.example.com" is "example.com". This value can be determined precisely with a list like the public suffix list (https://publicsuffix.org). Trying to approximate this by simply taking the last two labels will not work well for TLDs such as "co.uk". keyword
dns.question.subdomain The subdomain is all of the labels under the registered_domain. If the domain has multiple levels of subdomain, such as "sub2.sub1.example.com", the subdomain field should contain "sub2.sub1", with no trailing period. keyword
dns.question.top_level_domain The effective top level domain (eTLD), also known as the domain suffix, is the last part of the domain name. For example, the top level domain for example.com is "com". This value can be determined precisely with a list like the public suffix list (https://publicsuffix.org). Trying to approximate this by simply taking the last label will not work well for effective TLDs such as "co.uk". keyword
dns.question.type The type of record being queried. keyword
dns.resolved_ip Array containing all IPs seen in answers.data. The answers array can be difficult to use, because of the variety of data formats it can contain. Extracting all IP addresses seen in there to dns.resolved_ip makes it possible to index them as IP addresses, and makes them easier to visualize and query for. ip
dns.response_code The DNS response code. keyword
dns.type The type of DNS event captured, query or answer. If your source of DNS events only gives you DNS queries, you should only create dns events of type dns.type:query. If your source of DNS events gives you answers as well, you should create one event per query (optionally as soon as the query is seen). And a second event containing all query details as well as an array of answers. keyword
ecs.version ECS version this event conforms to. ecs.version is a required field and must exist in all events. When querying across multiple indices -- which may conform to slightly different ECS versions -- this field lets integrations adjust to the schema version of the events. keyword
error.code Error code describing the error. keyword
error.message Error message. match_only_text
event.action The action captured by the event. This describes the information in the event. It is more specific than event.category. Examples are group-add, process-started, file-created. The value is normally defined by the implementer. keyword
event.category This is one of four ECS Categorization Fields, and indicates the second level in the ECS category hierarchy. event.category represents the "big buckets" of ECS categories. For example, filtering on event.category:process yields all events relating to process activity. This field is closely related to event.type, which is used as a subcategory. This field is an array. This will allow proper categorization of some events that fall in multiple categories. keyword
event.code Identification code for this event, if one exists. Some event sources use event codes to identify messages unambiguously, regardless of message language or wording adjustments over time. An example of this is the Windows Event ID. keyword
event.created event.created contains the date/time when the event was first read by an agent, or by your pipeline. This field is distinct from @timestamp in that @timestamp typically contain the time extracted from the original event. In most situations, these two timestamps will be slightly different. The difference can be used to calculate the delay between your source generating an event, and the time when your agent first processed it. This can be used to monitor your agent's or pipeline's ability to keep up with your event source. In case the two timestamps are identical, @timestamp should be used. date
event.dataset Event dataset constant_keyword
event.ingested Timestamp when an event arrived in the central data store. This is different from @timestamp, which is when the event originally occurred. It's also different from event.created, which is meant to capture the first time an agent saw the event. In normal conditions, assuming no tampering, the timestamps should chronologically look like this: @timestamp < event.created < event.ingested. date
event.kind This is one of four ECS Categorization Fields, and indicates the highest level in the ECS category hierarchy. event.kind gives high-level information about what type of information the event contains, without being specific to the contents of the event. For example, values of this field distinguish alert events from metric events. The value of this field can be used to inform how these kinds of events should be handled. They may warrant different retention, different access control, it may also help understand whether the data is coming in at a regular interval or not. keyword
event.module Event module constant_keyword
event.outcome This is one of four ECS Categorization Fields, and indicates the lowest level in the ECS category hierarchy. event.outcome simply denotes whether the event represents a success or a failure from the perspective of the entity that produced the event. Note that when a single transaction is described in multiple events, each event may populate different values of event.outcome, according to their perspective. Also note that in the case of a compound event (a single event that contains multiple logical events), this field should be populated with the value that best captures the overall success or failure from the perspective of the event producer. Further note that not all events will have an associated outcome. For example, this field is generally not populated for metric events, events with event.type:info, or any events for which an outcome does not make logical sense. keyword
event.provider Source of the event. Event transports such as Syslog or the Windows Event Log typically mention the source of an event. It can be the name of the software that generated the event (e.g. Sysmon, httpd), or of a subsystem of the operating system (kernel, Microsoft-Windows-Security-Auditing). keyword
event.sequence Sequence number of the event. The sequence number is a value published by some event sources, to make the exact ordering of events unambiguous, regardless of the timestamp precision. long
event.type This is one of four ECS Categorization Fields, and indicates the third level in the ECS category hierarchy. event.type represents a categorization "sub-bucket" that, when used along with the event.category field values, enables filtering events down to a level appropriate for single visualization. This field is an array. This will allow proper categorization of some events that fall in multiple event types. keyword
file.code_signature.exists Boolean to capture if a signature is present. boolean
file.code_signature.status Additional information about the certificate status. This is useful for logging cryptographic errors with the certificate validity or trust status. Leave unpopulated if the validity or trust of the certificate was unchecked. keyword
file.code_signature.subject_name Subject name of the code signer keyword
file.code_signature.trusted Stores the trust status of the certificate chain. Validating the trust of the certificate chain may be complicated, and this field should only be populated by tools that actively check the status. boolean
file.code_signature.valid Boolean to capture if the digital signature is verified against the binary content. Leave unpopulated if a certificate was unchecked. boolean
file.directory Directory where the file is located. It should include the drive letter, when appropriate. keyword
file.extension File extension, excluding the leading dot. Note that when the file name has multiple extensions (example.tar.gz), only the last one should be captured ("gz", not "tar.gz"). keyword
file.hash.md5 MD5 hash. keyword
file.hash.sha1 SHA1 hash. keyword
file.hash.sha256 SHA256 hash. keyword
file.hash.sha512 SHA512 hash. keyword
file.name Name of the file including the extension, without the directory. keyword
file.path Full path to the file, including the file name. It should include the drive letter, when appropriate. keyword
file.path.text Multi-field of file.path. match_only_text
file.pe.architecture CPU architecture target for the file. keyword
file.pe.company Internal company name of the file, provided at compile-time. keyword
file.pe.description Internal description of the file, provided at compile-time. keyword
file.pe.file_version Internal version of the file, provided at compile-time. keyword
file.pe.imphash A hash of the imports in a PE file. An imphash -- or import hash -- can be used to fingerprint binaries even after recompilation or other code-level transformations have occurred, which would change more traditional hash values. Learn more at https://www.fireeye.com/blog/threat-research/2014/01/tracking-malware-import-hashing.html. keyword
file.pe.original_file_name Internal name of the file, provided at compile-time. keyword
file.pe.product Internal product name of the file, provided at compile-time. keyword
group.domain Name of the directory the group is a member of. For example, an LDAP or Active Directory domain name. keyword
group.id Unique identifier for the group on the system/platform. keyword
group.name Name of the group. keyword
host.architecture Operating system architecture. keyword
host.containerized If the host is a container. boolean
host.domain Name of the domain of which the host is a member. For example, on Windows this could be the host's Active Directory domain or NetBIOS domain name. For Linux this could be the domain of the host's LDAP provider. keyword
host.hostname Hostname of the host. It normally contains what the hostname command returns on the host machine. keyword
host.id Unique host id. As hostname is not always unique, use values that are meaningful in your environment. Example: The current usage of beat.name. keyword
host.ip Host ip addresses. ip
host.mac Host mac addresses. keyword
host.name Name of the host. It can contain what hostname returns on Unix systems, the fully qualified domain name, or a name specified by the user. The sender decides which value to use. keyword
host.os.build OS build information. keyword
host.os.codename OS codename, if any. keyword
host.os.family OS family (such as redhat, debian, freebsd, windows). keyword
host.os.kernel Operating system kernel version as a raw string. keyword
host.os.name Operating system name, without the version. keyword
host.os.name.text Multi-field of host.os.name. text
host.os.platform Operating system platform (such centos, ubuntu, windows). keyword
host.os.version Operating system version as a raw string. keyword
host.type Type of host. For Cloud providers this can be the machine type like t2.medium. If vm, this could be the container, for example, or other information meaningful in your environment. keyword
input.type Type of Filebeat input. keyword
log.file.device_id ID of the device containing the filesystem where the file resides. keyword
log.file.fingerprint The sha256 fingerprint identity of the file when fingerprinting is enabled. keyword
log.file.idxhi The high-order part of a unique identifier that is associated with a file. (Windows-only) keyword
log.file.idxlo The low-order part of a unique identifier that is associated with a file. (Windows-only) keyword
log.file.inode Inode number of the log file. keyword
log.file.path Full path to the log file this event came from, including the file name. It should include the drive letter, when appropriate. If the event wasn't read from a log file, do not populate this field. keyword
log.file.vol The serial number of the volume that contains a file. (Windows-only) keyword
log.level Original log level of the log event. If the source of the event provides a log level or textual severity, this is the one that goes in log.level. If your source doesn't specify one, you may put your event transport's severity here (e.g. Syslog severity). Some examples are warn, err, i, informational. keyword
log.offset Offset of the entry in the log file. long
message For log events the message field contains the log message, optimized for viewing in a log viewer. For structured logs without an original message field, other fields can be concatenated to form a human-readable summary of the event. If multiple messages exist, they can be combined into one message. match_only_text
network.community_id A hash of source and destination IPs and ports, as well as the protocol used in a communication. This is a tool-agnostic standard to identify flows. Learn more at https://github.com/corelight/community-id-spec. keyword
network.direction Direction of the network traffic. When mapping events from a host-based monitoring context, populate this field from the host's point of view, using the values "ingress" or "egress". When mapping events from a network or perimeter-based monitoring context, populate this field from the point of view of the network perimeter, using the values "inbound", "outbound", "internal" or "external". Note that "internal" is not crossing perimeter boundaries, and is meant to describe communication between two hosts within the perimeter. Note also that "external" is meant to describe traffic between two hosts that are external to the perimeter. This could for example be useful for ISPs or VPN service providers. keyword
network.protocol In the OSI Model this would be the Application Layer protocol. For example, http, dns, or ssh. The field value must be normalized to lowercase for querying. keyword
network.transport Same as network.iana_number, but instead using the Keyword name of the transport layer (udp, tcp, ipv6-icmp, etc.) The field value must be normalized to lowercase for querying. keyword
network.type In the OSI Model this would be the Network Layer. ipv4, ipv6, ipsec, pim, etc The field value must be normalized to lowercase for querying. keyword
process.args Array of process arguments, starting with the absolute path to the executable. May be filtered to protect sensitive information. keyword
process.args_count Length of the process.args array. This field can be useful for querying or performing bucket analysis on how many arguments were provided to start a process. More arguments may be an indication of suspicious activity. long
process.command_line Full command line that started the process, including the absolute path to the executable, and all arguments. Some arguments may be filtered to protect sensitive information. wildcard
process.command_line.text Multi-field of process.command_line. match_only_text
process.entity_id Unique identifier for the process. The implementation of this is specified by the data source, but some examples of what could be used here are a process-generated UUID, Sysmon Process GUIDs, or a hash of some uniquely identifying components of a process. Constructing a globally unique identifier is a common practice to mitigate PID reuse as well as to identify a specific process over time, across multiple monitored hosts. keyword
process.executable Absolute path to the process executable. keyword
process.executable.text Multi-field of process.executable. match_only_text
process.hash.md5 MD5 hash. keyword
process.hash.sha1 SHA1 hash. keyword
process.hash.sha256 SHA256 hash. keyword
process.hash.sha512 SHA512 hash. keyword
process.name Process name. Sometimes called program name or similar. keyword
process.name.text Multi-field of process.name. match_only_text
process.parent.args Array of process arguments, starting with the absolute path to the executable. May be filtered to protect sensitive information. keyword
process.parent.args_count Length of the process.args array. This field can be useful for querying or performing bucket analysis on how many arguments were provided to start a process. More arguments may be an indication of suspicious activity. long
process.parent.command_line Full command line that started the process, including the absolute path to the executable, and all arguments. Some arguments may be filtered to protect sensitive information. wildcard
process.parent.command_line.text Multi-field of process.parent.command_line. match_only_text
process.parent.entity_id Unique identifier for the process. The implementation of this is specified by the data source, but some examples of what could be used here are a process-generated UUID, Sysmon Process GUIDs, or a hash of some uniquely identifying components of a process. Constructing a globally unique identifier is a common practice to mitigate PID reuse as well as to identify a specific process over time, across multiple monitored hosts. keyword
process.parent.executable Absolute path to the process executable. keyword
process.parent.executable.text Multi-field of process.parent.executable. match_only_text
process.parent.name Process name. Sometimes called program name or similar. keyword
process.parent.name.text Multi-field of process.parent.name. match_only_text
process.parent.pid Process id. long
process.pe.architecture CPU architecture target for the file. keyword
process.pe.company Internal company name of the file, provided at compile-time. keyword
process.pe.description Internal description of the file, provided at compile-time. keyword
process.pe.file_version Internal version of the file, provided at compile-time. keyword
process.pe.imphash A hash of the imports in a PE file. An imphash -- or import hash -- can be used to fingerprint binaries even after recompilation or other code-level transformations have occurred, which would change more traditional hash values. Learn more at https://www.fireeye.com/blog/threat-research/2014/01/tracking-malware-import-hashing.html. keyword
process.pe.original_file_name Internal name of the file, provided at compile-time. keyword
process.pe.product Internal product name of the file, provided at compile-time. keyword
process.pid Process id. long
process.title Process title. The proctitle, some times the same as process name. Can also be different: for example a browser setting its title to the web page currently opened. keyword
process.title.text Multi-field of process.title. match_only_text
process.working_directory The working directory of the process. keyword
process.working_directory.text Multi-field of process.working_directory. match_only_text
registry.data.strings Content when writing string types. Populated as an array when writing string data to the registry. For single string registry types (REG_SZ, REG_EXPAND_SZ), this should be an array with one string. For sequences of string with REG_MULTI_SZ, this array will be variable length. For numeric data, such as REG_DWORD and REG_QWORD, this should be populated with the decimal representation (e.g "1"). wildcard
registry.data.type Standard registry type for encoding contents keyword
registry.hive Abbreviated name for the hive. keyword
registry.key Hive-relative path of keys. keyword
registry.path Full path, including hive, key and value keyword
registry.value Name of the value written. keyword
related.hash All the hashes seen on your event. Populating this field, then using it to search for hashes can help in situations where you're unsure what the hash algorithm is (and therefore which key name to search). keyword
related.hosts All hostnames or other host identifiers seen on your event. Example identifiers include FQDNs, domain names, workstation names, or aliases. keyword
related.ip All of the IPs seen on your event. ip
related.user All the user names or other user identifiers seen on the event. keyword
rule.name The name of the rule or signature generating the event. keyword
service.name Name of the service data is collected from. The name of the service is normally user given. This allows for distributed services that run on multiple hosts to correlate the related instances based on the name. In the case of Elasticsearch the service.name could contain the cluster name. For Beats the service.name is by default a copy of the service.type field if no name is specified. keyword
service.type The type of the service data is collected from. The type can be used to group and correlate logs and metrics from one service type. Example: If logs or metrics are collected from Elasticsearch, service.type would be elasticsearch. keyword
source.domain The domain name of the source system. This value may be a host name, a fully qualified domain name, or another host naming format. The value may derive from the original event or be added from enrichment. keyword
source.ip IP address of the source (IPv4 or IPv6). ip
source.port Port of the source. long
sysmon.dns.status Windows status code returned for the DNS query. keyword
sysmon.file.archived Indicates if the deleted file was archived. boolean
sysmon.file.is_executable Indicates if the deleted file was an executable. boolean
tags List of keywords used to tag each event. keyword
user.domain Name of the directory the user is a member of. For example, an LDAP or Active Directory domain name. keyword
user.id Unique identifier of the user. keyword
user.name Short name or login of the user. keyword
user.name.text Multi-field of user.name. match_only_text
user.target.group.domain Name of the directory the group is a member of. For example, an LDAP or Active Directory domain name. keyword
user.target.group.id Unique identifier for the group on the system/platform. keyword
user.target.group.name Name of the group. keyword
user.target.name Short name or login of the user. keyword
user.target.name.text Multi-field of user.target.name. match_only_text
winlog.activity_id A globally unique identifier that identifies the current activity. The events that are published with this identifier are part of the same activity. keyword
winlog.api The event log API type used to read the record. The possible values are "wineventlog" for the Windows Event Log API or "eventlogging" for the Event Logging API. The Event Logging API was designed for Windows Server 2003 or Windows 2000 operating systems. In Windows Vista, the event logging infrastructure was redesigned. On Windows Vista or later operating systems, the Windows Event Log API is used. Winlogbeat automatically detects which API to use for reading event logs. keyword
winlog.channel The name of the channel from which this record was read. This value is one of the names from the event_logs collection in the configuration. keyword
winlog.computer_name The name of the computer that generated the record. When using Windows event forwarding, this name can differ from agent.hostname. keyword
winlog.event_data The event-specific data. This field is mutually exclusive with user_data. If you are capturing event data on versions prior to Windows Vista, the parameters in event_data are named param1, param2, and so on, because event log parameters are unnamed in earlier versions of Windows. object
winlog.event_data.AuthenticationPackageName keyword
winlog.event_data.Binary keyword
winlog.event_data.BitlockerUserInputTime keyword
winlog.event_data.BootMode keyword
winlog.event_data.BootType keyword
winlog.event_data.BuildVersion keyword
winlog.event_data.ClientInfo keyword
winlog.event_data.Company keyword
winlog.event_data.Configuration keyword
winlog.event_data.CorruptionActionState keyword
winlog.event_data.CreationUtcTime keyword
winlog.event_data.Description keyword
winlog.event_data.Detail keyword
winlog.event_data.DeviceName keyword
winlog.event_data.DeviceNameLength keyword
winlog.event_data.DeviceTime keyword
winlog.event_data.DeviceVersionMajor keyword
winlog.event_data.DeviceVersionMinor keyword
winlog.event_data.DriveName keyword
winlog.event_data.DriverName keyword
winlog.event_data.DriverNameLength keyword
winlog.event_data.DwordVal keyword
winlog.event_data.EntryCount keyword
winlog.event_data.EventType keyword
winlog.event_data.ExtraInfo keyword
winlog.event_data.FailureName keyword
winlog.event_data.FailureNameLength keyword
winlog.event_data.FileVersion keyword
winlog.event_data.FinalStatus keyword
winlog.event_data.Group keyword
winlog.event_data.IdleImplementation keyword
winlog.event_data.IdleStateCount keyword
winlog.event_data.ImpersonationLevel keyword
winlog.event_data.IntegrityLevel keyword
winlog.event_data.IpAddress keyword
winlog.event_data.IpPort keyword
winlog.event_data.KeyLength keyword
winlog.event_data.LastBootGood keyword
winlog.event_data.LastShutdownGood keyword
winlog.event_data.LmPackageName keyword
winlog.event_data.LogonGuid keyword
winlog.event_data.LogonId keyword
winlog.event_data.LogonProcessName keyword
winlog.event_data.LogonType keyword
winlog.event_data.MajorVersion keyword
winlog.event_data.MaximumPerformancePercent keyword
winlog.event_data.MemberName keyword
winlog.event_data.MemberSid keyword
winlog.event_data.MinimumPerformancePercent keyword
winlog.event_data.MinimumThrottlePercent keyword
winlog.event_data.MinorVersion keyword
winlog.event_data.NewProcessId keyword
winlog.event_data.NewProcessName keyword
winlog.event_data.NewSchemeGuid keyword
winlog.event_data.NewTime keyword
winlog.event_data.NominalFrequency keyword
winlog.event_data.Number keyword
winlog.event_data.OldSchemeGuid keyword
winlog.event_data.OldTime keyword
winlog.event_data.OriginalFileName keyword
winlog.event_data.Path keyword
winlog.event_data.PerformanceImplementation keyword
winlog.event_data.PreviousCreationUtcTime keyword
winlog.event_data.PreviousTime keyword
winlog.event_data.PrivilegeList keyword
winlog.event_data.ProcessId keyword
winlog.event_data.ProcessName keyword
winlog.event_data.ProcessPath keyword
winlog.event_data.ProcessPid keyword
winlog.event_data.Product keyword
winlog.event_data.PuaCount keyword
winlog.event_data.PuaPolicyId keyword
winlog.event_data.QfeVersion keyword
winlog.event_data.Reason keyword
winlog.event_data.SchemaVersion keyword
winlog.event_data.ScriptBlockText keyword
winlog.event_data.ServiceName keyword
winlog.event_data.ServiceVersion keyword
winlog.event_data.Session keyword
winlog.event_data.ShutdownActionType keyword
winlog.event_data.ShutdownEventCode keyword
winlog.event_data.ShutdownReason keyword
winlog.event_data.Signature keyword
winlog.event_data.SignatureStatus keyword
winlog.event_data.Signed keyword
winlog.event_data.StartTime keyword
winlog.event_data.State keyword
winlog.event_data.Status keyword
winlog.event_data.StopTime keyword
winlog.event_data.SubjectDomainName keyword
winlog.event_data.SubjectLogonId keyword
winlog.event_data.SubjectUserName keyword
winlog.event_data.SubjectUserSid keyword
winlog.event_data.TSId keyword
winlog.event_data.TargetDomainName keyword
winlog.event_data.TargetInfo keyword
winlog.event_data.TargetLogonGuid keyword
winlog.event_data.TargetLogonId keyword
winlog.event_data.TargetServerName keyword
winlog.event_data.TargetUserName keyword
winlog.event_data.TargetUserSid keyword
winlog.event_data.TerminalSessionId keyword
winlog.event_data.TokenElevationType keyword
winlog.event_data.TransmittedServices keyword
winlog.event_data.Type keyword
winlog.event_data.UserSid keyword
winlog.event_data.Version keyword
winlog.event_data.Workstation keyword
winlog.event_data.param1 keyword
winlog.event_data.param2 keyword
winlog.event_data.param3 keyword
winlog.event_data.param4 keyword
winlog.event_data.param5 keyword
winlog.event_data.param6 keyword
winlog.event_data.param7 keyword
winlog.event_data.param8 keyword
winlog.event_id The event identifier. The value is specific to the source of the event. keyword
winlog.keywords The keywords are used to classify an event. keyword
winlog.opcode The opcode defined in the event. Task and opcode are typically used to identify the location in the application from where the event was logged. keyword
winlog.process.pid The process_id of the Client Server Runtime Process. long
winlog.process.thread.id long
winlog.provider_guid A globally unique identifier that identifies the provider that logged the event. keyword
winlog.provider_name The source of the event log record (the application or service that logged the record). keyword
winlog.record_id The record ID of the event log record. The first record written to an event log is record number 1, and other records are numbered sequentially. If the record number reaches the maximum value (232 for the Event Logging API and 264 for the Windows Event Log API), the next record number will be 0. keyword
winlog.related_activity_id A globally unique identifier that identifies the activity to which control was transferred to. The related events would then have this identifier as their activity_id identifier. keyword
winlog.task The task defined in the event. Task and opcode are typically used to identify the location in the application from where the event was logged. The category used by the Event Logging API (on pre Windows Vista operating systems) is written to this field. keyword
winlog.user.domain The domain that the account associated with this event is a member of. keyword
winlog.user.identifier The security identifier (SID) of the account associated with this event. keyword
winlog.user.name Name of the user associated with this event. keyword
winlog.user.type The type of account associated with this event. keyword
winlog.user_data The event specific data. This field is mutually exclusive with event_data. object
winlog.version The version number of the event's definition. long

This integration includes one or more Kibana dashboards that visualizes the data collected by the integration. The screenshots below illustrate how the ingested data is displayed.

kibana sysmon linux
Changelog
Version Details Minimum Kibana version
1.9.1 Enhancement (View pull request)
Transfer package ownership to elastic/security-service-integrations.
9.0.0
8.11.0
1.9.0 Enhancement (View pull request)
Allow @custom pipeline access to event.original without setting preserve_original_event.
9.0.0
8.11.0
1.8.1 Bug fix (View pull request)
Handle events without event_data
9.0.0
8.4.0
1.8.0 Enhancement (View pull request)
Add 9.0.0 constraint and update to ECS 8.17.0
9.0.0
8.4.0
1.7.2 Bug fix (View pull request)
Update links to getting started docs
8.4.0
1.7.1 Bug fix (View pull request)
Use triple-brace Mustache templating when referencing variables in ingest pipelines.
8.4.0
1.7.0 Enhancement (View pull request)
Tighten IPv4 extraction from IPv4-mapped IPv6 addresses.
8.4.0
1.6.3 Bug fix (View pull request)
Fix IPv6 cleanup step.
8.4.0
1.6.2 Enhancement (View pull request)
Changed owners
8.4.0
1.6.1 Bug fix (View pull request)
Fix exclude_files pattern.
8.4.0
1.6.0 Enhancement (View pull request)
ECS version updated to 8.11.0.
8.4.0
1.5.1 Bug fix (View pull request)
Fix mapping of dns.answers
8.4.0
1.5.0 Enhancement (View pull request)
Adapt fields for changes in file system info
8.4.0
1.4.0 Enhancement (View pull request)
ECS version updated to 8.10.0.
8.4.0
1.3.0 Enhancement (View pull request)
The format_version in the package manifest changed from 2.11.0 to 3.0.0. Removed dotted YAML keys from package manifest. Added 'owner.type: elastic' to package manifest.
8.4.0
1.2.0 Enhancement (View pull request)
Add tags.yml file so that integration's dashboards and saved searches are tagged with "Security Solution" and displayed in the Security Solution UI.
8.4.0
1.1.0 Enhancement (View pull request)
Update package to ECS 8.9.0.
8.4.0
1.0.0 Enhancement (View pull request)
Release Sysmon for Linux as GA.
8.4.0
0.5.0 Enhancement (View pull request)
Ensure event.kind is correctly set for pipeline errors.
8.4.0
0.4.0 Enhancement (View pull request)
Update package to ECS 8.8.0.
8.4.0
0.3.0 Enhancement (View pull request)
Update package-spec version to 2.7.0.
8.4.0
0.2.0 Enhancement (View pull request)
Update package to ECS 8.7.0.
8.4.0
0.1.0 Enhancement (View pull request)
initial release
8.4.0