Type to search.

kube-apiserver

Serverless Observability

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Serverless Security

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Stack 9.5+

The Elastic Stack includes Elastic's core products such as Elasticsearch, Kibana, Logstash, and Beats.

Availability

  • Generally available since 9.5

    This functionality is generally available and ready for production usage.

Unless stated otherwise on the page, this functionality is available when your Elastic Stack is deployed on Elastic Cloud Hosted, Elastic Cloud Enterprise, Elastic Cloud on Kubernetes, and self-managed environments.

This documentation corresponds to the latest patch available for each minor version. If you're not using the latest patch, check the release notes for changes.

Version 1.86.0 (View all)
Subscription level
What's this?
Basic
Ingestion method(s) API, AWS CloudWatch, Azure Event Hub, File, GCP Pub/Sub
Minimum Kibana version(s) 9.5.0

This is the apiserver dataset of the Kubernetes package, in charge of retrieving metrics from the Kubernetes API (available at /metrics).

This metricset needs access to the apiserver component of Kubernetes, accessible typically by any POD via the kubernetes.default service or via environment variables (KUBERNETES_SERVICE_HOST and KUBERNETES_SERVICE_PORT).

If Leader Election is activated (default behaviour) only the elastic agent which holds the leadership lock will retrieve metrics from the apiserver. This is relevant in multi-node kubernetes cluster and prevents duplicate data.

When the API uses https, the pod will need to authenticate using its default token and trust the server using the appropriate CA file.

Configuration example using https and token based authentication:

In order to access the /metrics path of the API service, some Kubernetes environments might require the following permission to be added to a ClusterRole.

YAML
rules:
- nonResourceURLs:
  - /metrics
  verbs:
  - get
Example
JSON
{
    "kubernetes": {
        "apiserver": {
            "major": {
                "version": "1"
            },
            "minor": {
                "version": "27"
            },
            "request": {
                "component": "apiserver",
                "duration": {
                    "us": {
                        "bucket": {
                            "5000": 2,
                            "25000": 13,
                            "50000": 13,
                            "100000": 13,
                            "200000": 14,
                            "400000": 14,
                            "600000": 14,
                            "800000": 14,
                            "1000000": 14,
                            "1250000": 14,
                            "1500000": 14,
                            "2000000": 14,
                            "3000000": 14,
                            "4000000": 14,
                            "5000000": 14,
                            "6000000": 14,
                            "8000000": 14,
                            "10000000": 14,
                            "15000000": 14,
                            "20000000": 14,
                            "30000000": 14,
                            "45000000": 14,
                            "60000000": 14,
                            "+Inf": 14
                        },
                        "count": 14,
                        "sum": 215052
                    }
                },
                "group": "flowcontrol.apiserver.k8s.io",
                "resource": "flowschemas",
                "scope": "resource",
                "subresource": "status",
                "verb": "APPLY",
                "version": "v1beta3"
            }
        }
    }
}
Exported fields
Field Description Type Unit Metric Type
@timestamp Date/time when the event originated. This is the date/time extracted from the event, typically representing when the event was generated by the source. If the event source has no original timestamp, this value is typically populated by the first time the event was received by the pipeline. Required field for all events. date
agent.id Unique identifier of this agent (if one exists). Example: For Beats this would be beat.id. keyword
cloud.account.id The cloud account or organization id used to identify different entities in a multi-tenant environment. Examples: AWS account id, Google Cloud ORG Id, or other unique identifier. keyword
cloud.availability_zone Availability zone in which this host, resource, or service is located. keyword
cloud.image.id Image ID for the cloud instance. keyword
cloud.instance.id Instance ID of the host machine. keyword
cloud.instance.name Instance name of the host machine. keyword
cloud.machine.type Machine type of the host machine. keyword
cloud.project.id The cloud project identifier. Examples: Google Cloud Project id, Azure Project id. keyword
cloud.provider Name of the cloud provider. Example values are aws, azure, gcp, or digitalocean. keyword
cloud.region Region in which this host, resource, or service is located. keyword
container.id Unique container id. keyword
container.image.name Name of the image the container was built on. keyword
container.labels Image labels. object
container.name Container name. keyword
data_stream.dataset The field can contain anything that makes sense to signify the source of the data. Examples include nginx.access, prometheus, endpoint etc. For data streams that otherwise fit, but that do not have dataset set we use the value "generic" for the dataset value. event.dataset should have the same value as data_stream.dataset. Beyond the Elasticsearch data stream naming criteria noted above, the dataset value has additional restrictions: * Must not contain - * No longer than 100 characters constant_keyword
data_stream.namespace A user defined namespace. Namespaces are useful to allow grouping of data. Many users already organize their indices this way, and the data stream naming scheme now provides this best practice as a default. Many users will populate this field with default. If no value is used, it falls back to default. Beyond the Elasticsearch index naming criteria noted above, namespace value has the additional restrictions: * Must not contain - * No longer than 100 characters constant_keyword
data_stream.type An overarching type for the data stream. Currently allowed values are "logs" and "metrics". We expect to also add "traces" and "synthetics" in the near future. constant_keyword
ecs.version ECS version this event conforms to. ecs.version is a required field and must exist in all events. When querying across multiple indices -- which may conform to slightly different ECS versions -- this field lets integrations adjust to the schema version of the events. keyword
host.architecture Operating system architecture. keyword
host.containerized If the host is a container. boolean
host.domain Name of the domain of which the host is a member. For example, on Windows this could be the host's Active Directory domain or NetBIOS domain name. For Linux this could be the domain of the host's LDAP provider. keyword
host.hostname Hostname of the host. It normally contains what the hostname command returns on the host machine. keyword
host.id Unique host id. As hostname is not always unique, use values that are meaningful in your environment. Example: The current usage of beat.name. keyword
host.ip Host ip addresses. ip
host.mac Host MAC addresses. The notation format from RFC 7042 is suggested: Each octet (that is, 8-bit byte) is represented by two [uppercase] hexadecimal digits giving the value of the octet as an unsigned integer. Successive octets are separated by a hyphen. keyword
host.name Name of the host. It can contain what hostname returns on Unix systems, the fully qualified domain name (FQDN), or a name specified by the user. The recommended value is the lowercase FQDN of the host. keyword
host.os.build OS build information. keyword
host.os.codename OS codename, if any. keyword
host.os.family OS family (such as redhat, debian, freebsd, windows). keyword
host.os.kernel Operating system kernel version as a raw string. keyword
host.os.name Operating system name, without the version. keyword
host.os.name.text Multi-field of host.os.name. match_only_text
host.os.platform Operating system platform (such centos, ubuntu, windows). keyword
host.os.version Operating system version as a raw string. keyword
host.type Type of host. For Cloud providers this can be the machine type like t2.medium. If vm, this could be the container, for example, or other information meaningful in your environment. keyword
kubernetes.apiserver.audit.event.count Number of audit events long counter
kubernetes.apiserver.audit.rejected.count Number of audit rejected events long counter
kubernetes.apiserver.client.request.count Number of requests as client long counter
kubernetes.apiserver.etcd.object.count Number of kubernetes objects at etcd long gauge
kubernetes.apiserver.major.version API Server major version. keyword
kubernetes.apiserver.minor.version API Server minor version. keyword
kubernetes.apiserver.process.cpu.sec CPU seconds double counter
kubernetes.apiserver.process.fds.open.count Number of open file descriptors long gauge
kubernetes.apiserver.process.memory.resident.bytes Bytes in resident memory long byte gauge
kubernetes.apiserver.process.memory.virtual.bytes Bytes in virtual memory long byte gauge
kubernetes.apiserver.process.started.sec Seconds since the process started double gauge
kubernetes.apiserver.request.code HTTP code keyword
kubernetes.apiserver.request.component Component handling the request keyword
kubernetes.apiserver.request.content_type Request HTTP content type keyword
kubernetes.apiserver.request.count Number of requests long counter
kubernetes.apiserver.request.current.count Inflight requests long counter
kubernetes.apiserver.request.dry_run Wether the request uses dry run keyword
kubernetes.apiserver.request.duration.us.bucket.* Request duration, histogram buckets object
kubernetes.apiserver.request.duration.us.count Request duration, number of operations long counter
kubernetes.apiserver.request.duration.us.sum Request duration, sum in microseconds long micros counter
kubernetes.apiserver.request.group API group for the resource keyword
kubernetes.apiserver.request.handler Request handler keyword
kubernetes.apiserver.request.host Request host keyword
kubernetes.apiserver.request.kind Kind of request keyword
kubernetes.apiserver.request.longrunning.count Number of requests active long running requests long counter
kubernetes.apiserver.request.method HTTP method keyword
kubernetes.apiserver.request.resource Requested resource keyword
kubernetes.apiserver.request.scope Request scope (cluster, namespace, resource) keyword
kubernetes.apiserver.request.subresource Requested subresource keyword
kubernetes.apiserver.request.verb HTTP verb keyword
kubernetes.apiserver.request.version version for the group keyword
kubernetes.apiserver.response.size.bytes.bucket.* Response size distribution in bytes for each group, version, verb, resource, subresource, scope and component. object
kubernetes.apiserver.response.size.bytes.count Number of responses to requests long counter
kubernetes.apiserver.response.size.bytes.sum Sum of responses sizes in bytes long byte counter
kubernetes.apiserver.watch.events.kind Resource kind of the watch event keyword
kubernetes.apiserver.watch.events.size.bytes.bucket.* Watch event size distribution in bytes object
kubernetes.apiserver.watch.events.size.bytes.count Number of watch events long counter
kubernetes.apiserver.watch.events.size.bytes.sum Sum of watch events sizes in bytes long byte counter
orchestrator.cluster.name Name of the cluster. keyword
orchestrator.cluster.url URL of the API used to manage the cluster. keyword
service.address Address where data about this service was collected from. This should be a URI, network address (ipv4:port or [ipv6]:port) or a resource path (sockets). keyword
service.type The type of the service data is collected from. The type can be used to group and correlate logs and metrics from one service type. Example: If logs or metrics are collected from Elasticsearch, service.type would be elasticsearch. keyword

This integration includes one or more Kibana dashboards that visualizes the data collected by the integration. The screenshots below illustrate how the ingested data is displayed.

Metricbeat Kubernetes Overview
Changelog
Version Details Minimum Kibana version
1.86.0 Enhancement (View pull request)
Add the single_input option to the container logs input, enabled by default, and send it to Elastic Agent. When enabled, Elastic Agent 9.6 and later collects container logs with a single filestream input instead of one input per container.
9.5.0
1.85.6 Bug fix (View pull request)
Map GKE audit log protoPayload fields to ECS (user.name, user.id, user.email, source.ip, user_agent.original, event.action, orchestrator.namespace, orchestrator.resource.*) in the audit_logs data stream.
9.5.0
1.85.5 Enhancement (View pull request)
Add ignore_older option to audit_logs filestream input.
9.5.0
1.85.4 Enhancement (View pull request)
Add kubernetes.container.type field to the state_container data stream and set Kibana condition to ^9.5.0 (field available from Beats 9.5.0).
9.5.0
1.85.3 Bug fix (View pull request)
Update user.extra and impersonatedUser.extra field mapping in the kubernetes.audit_logs ingest pipeline as a flattened object.
9.3.0
9.2.4
9.1.10
1.85.2 Enhancement (View pull request)
Add timeout setting to the kube-state-metrics input for tuning the HTTP request timeout on large clusters.
9.3.0
9.2.4
9.1.10
1.85.1 Bug fix (View pull request)
Add container_logs system tests and update base-fields.yml
9.3.0
9.2.4
9.1.10
1.85.0 Enhancement (View pull request)
Add client secret authentication support for Azure Event Hub with RBAC.
9.3.0
9.2.4
9.1.10
1.84.1 Bug fix (View pull request)
Add AWS authentication variables for CloudWatch input in audit_logs data stream and fix api_timeout variable name typo.
9.3.0
9.2.4
9.1.10
1.84.0 Enhancement (View pull request)
Add kubernetes.container.status.last_terminated_exitcode field to the state_container data stream.
9.3.0
9.2.4
9.1.10
1.83.1 Enhancement (View pull request)
Add timeout setting to the kube-state-metrics input for tuning the HTTP request timeout on large clusters.
9.0.0
8.15.0
1.83.0 Enhancement (View pull request)
Update the container logs documentation on how to ingest rotated logs, including GZIP-compressed logs.
9.0.0
8.15.0
1.82.1 Bug fix (View pull request)
Fix field rename error in audit logs ingest pipeline.
9.0.0
8.15.0
1.82.0 Enhancement (View pull request)
Allow to configure container_logs input id and update container logs documentation to include how to ingest rotated log files.
9.0.0
8.15.0
1.81.1 Bug fix (View pull request)
Fix processing of Azure AKS audit logs.
9.0.0
8.15.0
1.81.0 Enhancement (View pull request)
Support for collecting audit logs from cloud providers.
9.0.0
8.15.0
1.80.2 Bug fix (View pull request)
Fixed typos in ssl node descriptions in manifest.yml files.
9.0.0
8.15.0
1.80.1 Bug fix (View pull request)
Added description to ssl.certificate_authorities and ssl.verification_mode, including links to documentation.
9.0.0
8.15.0
1.80.0 Enhancement (View pull request)
Add support for Kibana 9.0.0
9.0.0
8.15.0
1.70.2 Enhancement (View pull request)
Update the container logs documentation
8.15.0
1.70.1 Bug fix (View pull request)
Fix kubernetes.pod.cpu.usage.nanocores unit
8.15.0
1.70.0 Enhancement (View pull request)
Make fingerprint configurable
8.15.0
1.69.0 Enhancement (View pull request)
Added datatype for audit log field annotations.pod-security_kubernetes_io/audit-violation
8.15.0
1.68.1 Bug fix (View pull request)
Fix Overview dashboard Kibana id
8.15.0
1.68.0 Enhancement (View pull request)
Use filestream fingerprint mode by default for container_logs datastream
8.15.0
1.67.0 Enhancement (View pull request)
Add both pod.{cpu,memory}.usage.node.pct and pod.{cpu,memory}.usage.limit.pct metrics to the Overview dashboard
8.15.0
1.66.4 Bug fix (View pull request)
Updating Cluster Overview Dashboard to use container.id as filter and replaced median functions from visualisations
8.15.0
1.66.3 Enhancement (View pull request)
Updating mapping of the field groups to keyword in kubernetes.audit_logs
8.15.0
1.66.2 Bug fix (View pull request)
Fixing missing processor block in kubernetes.audit_logs
8.15.0
1.66.1 Bug fix (View pull request)
Fixing Title in Volumes Dashboard
8.15.0
1.66.0 Enhancement (View pull request)
Adding Volume Usage per pod in Kubernetes Volume Dashboard
8.15.0
1.65.0 Enhancement (View pull request)
Add last_terminated_timestamp metric to the kubernetes.state_container datastream
8.15.0
1.64.0 Enhancement (View pull request)
Move namespace filter to the group level configuration
8.15.0
1.63.1 Bug fix (View pull request)
Fix typo in kubernetes.audit ingest pipeline
8.15.0
1.63.0 Enhancement (View pull request)
Add pod.status_reason and pod.status.ready_time fields to the state_pod datastream
8.15.0
1.62.1 Bug fix (View pull request)
Fix kubernetes.audit ingest pipeline
8.14.0
1.62.0 Enhancement (View pull request)
Add new mappings to the kubernetes.audit datastream
8.14.0
1.61.1 Bug fix (View pull request)
Remove percent unit for pod memory metrics
8.14.0
1.61.0 Enhancement (View pull request)
Remove deprecated fields and add missing status.last_terminated_reason metric
8.14.0
1.60.0 Bug fix (View pull request)
Updating Memory used vs total memory and Cores used vs total cores visualisations in Cluster Overview Dashboard
8.14.0
1.59.0 Enhancement (View pull request)
Add metadata fields to state_namespace data stream.
8.14.0
1.58.0 Enhancement (View pull request)
Migrate to format_version v3.
8.12.0
1.57.0 Enhancement (View pull request)
Container logs preserve original content based on pod annotations.
8.12.0
1.56.0 Enhancement (View pull request)
Add new fields to API server, state_node and persistent volume claim data streams.
8.12.0
1.55.1 Enhancement (View pull request)
Modify the field definitions to reference ECS.
8.11.0
1.55.0 Enhancement (View pull request)
Remove extra base fields from state data streams.
8.11.0
1.54.0 Enhancement (View pull request)
Expand condition support to remaining inputs
8.11.0
1.53.0 Enhancement (View pull request)
Update size of the metric visualizations
8.11.0
1.52.0 Enhancement (View pull request)
Add new data stream state_namespace.
8.11.0
1.51.0 Enhancement (View pull request)
Migrate Deployments dashboard visualizations to lens.
8.10.2
1.50.0 Enhancement (View pull request)
Migrate Cronjobs dashboard visualizations to lens
8.10.2
1.49.0 Enhancement (View pull request)
Migrate DaemonSets dashboard visualizations to lens.
8.10.2
1.48.0 Enhancement (View pull request)
Migrate StatefulSets dashboard visualizations to lens.
8.10.2
1.47.0 Enhancement (View pull request)
Migrate Jobs dashboard visualizations to lens.
8.10.2
1.46.0 Enhancement (View pull request)
Adapt fields for changes in file system info
8.10.1
1.45.0 Enhancement (View pull request)
Reroute container logs based on pod annotations.
8.10.0
1.44.0 Enhancement (View pull request)
Introducing kubernetes.deployment.status.* metrics
8.10.0
1.43.1 Enhancement (View pull request)
Updating index pattern for adHocDataviews for CCS use case
8.8.0
1.43.0 Enhancement (View pull request)
Expand index pattern for adHocDataviews for CCS use case
8.8.0
1.42.0 Enhancement (View pull request)
Add permissions to reroute events to logs-- for container_logs datastream
8.8.0
1.41.0 Enhancement (View pull request)
Enable time series data streams for the metrics datasets. This improves storage usage and query performance. For more details, see https://www.elastic.co/guide/en/elasticsearch/reference/current/tsds.html
8.8.0
1.40.0 Bug fix (View pull request)
Fix system tests for kubernetes integration for k8s v1.27.0
8.8.0
1.40.0-beta.2 Bug fix (View pull request)
Fix volume dashboard.
—
1.40.0-beta.1 Bug fix (View pull request)
Fix proxy and scheduler visualization with missing sort field.
—
1.40.0-beta Enhancement (View pull request)
Enable TSDS for metrics data_streams, except events for beta testing
—
1.39.0 Enhancement (View pull request)
Remove container.name as a dimension.
8.6.1
1.38.1 Enhancement (View pull request)
Switch max to last value on counter formulas and add missing sort field to proxy, controller manager and scheduler dashboard.
8.6.1
1.38.0 Enhancement (View pull request)
Fix Pod dashboard and remove some visualisations from Api Server dashboard to support TSDB migration
8.6.1
1.37.0 Enhancement (View pull request)
Update proxy, controller manager and scheduler dashboard to support TSDB.
8.6.1
1.36.0 Enhancement (View pull request)
Add container.name dimension to container data stream
8.6.1
1.35.0 Enhancement (View pull request)
Add NetworkUnavailable condition to state node
8.6.1
1.34.1 Enhancement (View pull request)
Add support for TSDB on all metric data streams except the state ones
8.6.1
1.34.0 Enhancement (View pull request)
Add support for TSDB on all state metric data streams
8.6.1
1.33.0 Enhancement (View pull request)
Add data_stream.dataset setting and custom yaml input.
8.6.1
1.32.2 Enhancement (View pull request)
Added link to docs for condition filter
8.6.1
1.32.1 Enhancement (View pull request)
Added categories and/or subcategories.
8.6.1
1.32.0 Enhancement (View pull request)
Add documentation for how to install alerts
8.6.1
1.31.2 Enhancement (View pull request)
Add system testing for state service datastream
8.6.1
1.31.1 Enhancement (View pull request)
Update controller manager, proxy and scheduler metrics and dashboards
8.6.1
1.31.0 Enhancement (View pull request)
Use datas_tream.dataset as pre filters for dashboards and remove tags
8.6.0
1.30.0 Enhancement (View pull request)
Add missing namespace_uid and namespace_labels fields
8.6.0
1.29.2 Bug fix (View pull request)
Fix function for memory node usage
8.5.0
1.29.1 Bug fix (View pull request)
Fix removed condition setting for container_logs
8.5.0
1.29.0 Bug fix (View pull request)
Remove "Control Plane" column from Node Information table
8.5.0
1.28.2 Bug fix (View pull request)
Fix Pod Memory usage panel title
8.5.0
1.28.1 Enhancement (View pull request)
Delete statefulset, job and cronjob visualizations from Cluster Overview dashboard
8.5.0
1.28.0 Enhancement (View pull request)
Adding banner for Kube-state metrics
8.5.0
1.27.1 Enhancement (View pull request)
Fix typo in cluster overview dashboard
8.5.0
1.27.0 Enhancement (View pull request)
New cluster overview dashboard
8.5.0
1.26.0 Enhancement (View pull request)
Add processors configuration option for Kubernetes data_streams
8.4.0
1.25.0 Enhancement (View pull request)
Add condition configuration option to container logs data stream
8.4.0
1.24.0 Enhancement (View pull request)
Add fields to audit logs data stream
8.4.0
1.23.1 Enhancement (View pull request)
Add missing dimension fields
8.4.0
1.23.0 Enhancement (View pull request)
Add fields to audit logs data stream
8.4.0
1.22.1 Enhancement (View pull request)
Fix overlapping fields in state_job data stream
8.4.0
1.22.0 Enhancement (View pull request)
Update apiserver and controllermanaged deprecated fields and dashboards
8.4.0
1.21.2 Bug fix (View pull request)
add container ID and pod name as part of Kubernetes Cotainer Logs filestream input
8.3.0
1.21.1 Enhancement (View pull request)
improved the wording of the link to Kubernetes documentation
8.3.0
1.21.0 Enhancement (View pull request)
Add new dashboards
8.3.0
1.20.0 Enhancement (View pull request)
Change fields type for audit_logs data_stream to use requestObject and responseObject fields of audit events. Disable dynamic mapping for audit_logs data_stream. Drop kubernetes.audit.responseObject.metadata and kubernetes.audit.requestObject.metadata
8.2.0
1.19.1 Enhancement (View pull request)
Add documentation for volume field
8.2.0
1.19.0 Enhancement (View pull request)
Add missed ecs fields
8.2.0
1.18.1 Enhancement (View pull request)
Add documentation for multi-fields
8.2.0
1.18.0 Enhancement (View pull request)
Fix k8s overview dashboard
8.2.0
1.17.3 Bug fix (View pull request)
Remove incorrectly tagged boolean dimension
8.0.0
7.16.0
1.17.2 Bug fix (View pull request)
Add missing metadata fields
8.0.0
7.16.0
1.17.1 Enhancement (View pull request)
Improve default ndjson parser configuration
—
1.17.0 Enhancement (View pull request)
Disable audit logs collection by default
—
1.16.0 Enhancement (View pull request)
Documentation improvements
—
1.15.0 Enhancement (View pull request)
Add ssl.certificate_authorities configuration
—
1.14.3 Bug fix (View pull request)
Add missing job.name and cronjob.name fields to state_container datastream
—
1.14.2 Bug fix (View pull request)
Add missing job.name and cronjob.name fields to container related datastreams
—
1.14.1 Bug fix (View pull request)
Add missing job.name and cronjob.name fields added by metadata generators
—
1.14.0 Enhancement (View pull request)
Tune state_metrics settings
—
1.13.0 Enhancement (View pull request)
Update to ECS 8.0
—
1.12.0 Enhancement (View pull request)
Expose add_recourse_metadata configuration option
—
1.11.0 Enhancement (View pull request)
Add memory.working_set.limit.pct for pod and container data streams
—
1.10.0 Enhancement (View pull request)
Add leader election in state_job data stream
—
1.9.0 Enhancement (View pull request)
Add missing fields
8.0.0
7.16.0
1.8.1 Bug fix (View pull request)
Set kubernetes.volume.fs.used.pct to scaled_float
8.0.0
7.16.0
1.8.0 Enhancement (View pull request)
Support json logs parsing
8.0.0
7.16.0
1.7.0 Enhancement (View pull request)
Add new audit logs data stream in kubernetes integration
8.0.0
7.16.0
1.6.0 Enhancement (View pull request)
Add skip_older option for event datastream
8.0.0
7.16.0
1.5.0 Enhancement (View pull request)
Revert Kubernetes namespace field breaking change
8.0.0
7.16.0
1.4.2 Enhancement (View pull request)
Add dimension fields
—
1.4.1 Enhancement (View pull request)
Remove overriding of index pattern on the Kubernetes overview dashboard
8.0.0
1.4.0 Enhancement (View pull request)
Use filestream input for container_logs data stream
—
1.3.3 Bug fix (View pull request)
Fix conditions of data_streams that are based on k8s labels & add condition in pipelines
—
1.3.2 Enhancement (View pull request)
Set default host for proxy to localhost
—
1.3.1 Enhancement (View pull request)
Uniform with guidelines
—
1.3.0 Enhancement (View pull request)
Add container_logs ecs fields
—
1.2.1 Bug fix (View pull request)
Update Kubernetes cluster_ip field type
—
1.2.0 Enhancement (View pull request)
Update Kubernetes namespace field
—
1.1.1 Bug fix (View pull request)
Update Kubernetes integration Readme
—
1.1.0 Enhancement (View pull request)
Update to ECS 1.12.0
7.15.0
1.0.0 Enhancement (View pull request)
Release Kubernetes as GA
—
0.14.1 Enhancement (View pull request)
Update default host in kubernetes proxy data stream in kubernetes integration
—
0.14.0 Enhancement (View pull request)
Add new container logs data stream in kubernetes integration
—
0.13.0 Enhancement (View pull request)
Leverage dynamic kubernetes provider for controller and scheduler datastream
—
0.12.2 Bug fix (View pull request)
Add missing field "kubernetes.daemonset.name" field for pod and container data streams
—
0.12.1 Bug fix (View pull request)
Add missing cluster filter for "orchestrator.cluster.name" field in [Metrics Kubernetes] Overview dashboard and Dashboard section in the integration overview page
—
0.12.0 Enhancement (View pull request)
Update kubernetes package ecs fields with orchestrator.cluster.url and orchestrator.cluster.name
—
0.11.1 Enhancement (View pull request)
Escape special characters in docs
—
0.11.0 Enhancement (View pull request)
Update documentation to fit mdx spec
—
0.10.0 Enhancement (View pull request)
Update integration description
—
0.9.1 Bug fix (View pull request)
Add missing field "kubernetes.daemonset.name" field for state_pod and state_container
—
0.9.0 Enhancement (View pull request)
Enhance kubernetes package with state_job data stream
—
0.8.0 Enhancement (View pull request)
Leverage leader election in kubernetes integration
—
0.7.0 Enhancement (View pull request)
Add _meta information to Kubernetes fields
—
0.6.0 Enhancement (View pull request)
Introduce kubernetes package granularity using input_groups
—
0.5.3 Enhancement (View pull request)
Add missing field "kubernetes.statefulset.replicas.ready"
—
0.5.2 Bug fix (View pull request)
Fix stack compatability
—
0.5.1 Bug fix (View pull request)
Fix references to env variables
—
0.5.0 Enhancement (View pull request)
Add missing field "kubernetes.selectors.*" and extra https settings for controllermanager and scheduler datastreams
—
0.4.5 Enhancement (View pull request)
Add missing field "kubernetes.pod.ip"
—
0.4.4 Enhancement (View pull request)
Updating package owner
—
0.4.3 Bug fix (View pull request)
Correct sample event file.
—
0.4.2 Bug fix (View pull request)
Change kibana.version constraint to be more conservative.
—
0.4.1 Enhancement (View pull request)
Add missing fields
—
0.1.0 Enhancement (View pull request)
initial release
—