Type to search.

Microsoft Entra ID Entity Analytics

Serverless Observability

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Serverless Security

Elastic Cloud Serverless projects are autoscaled environments, fully managed by Elastic and available on Elastic Cloud.

Availability

  • Generally available

    This functionality is generally available and ready for production usage.

Stack 9.5+

The Elastic Stack includes Elastic's core products such as Elasticsearch, Kibana, Logstash, and Beats.

Availability

  • Generally available since 9.5

    This functionality is generally available and ready for production usage.

Unless stated otherwise on the page, this functionality is available when your Elastic Stack is deployed on Elastic Cloud Hosted, Elastic Cloud Enterprise, Elastic Cloud on Kubernetes, and self-managed environments.

This documentation corresponds to the latest patch available for each minor version. If you're not using the latest patch, check the release notes for changes.

Version 1.15.1 (View all)
Managed integration release status Availability Beta This functionality is in beta and is not ready for production usage. For beta features, the design and code is less mature than official GA features and is being provided as-is with no warranties. Beta features are not subject to the support SLA of official GA features. Specific Support terms apply.
Subscription level
What's this?
Basic
Developed by
What's this?
Elastic
Ingestion method(s) API
Minimum Kibana version(s) 9.5.0
Important - Managed integrations on Elastic Cloud Hosted The Elastic Stack includes Elastic's core products such as Elasticsearch, Kibana, Logstash, and Beats. Availability Generally available since 9.5 This functionality is generally available and ready for production usage. Unless stated otherwise on the page, this functionality is available when your Elastic Stack is deployed on Elastic Cloud Hosted, Elastic Cloud Enterprise, Elastic Cloud on Kubernetes, and self-managed environments. This documentation corresponds to the latest patch available for each minor version. If you're not using the latest patch, check the release notes for changes.

You can use this integration as an Elastic Managed integration on Elastic Cloud Hosted deployments running this version or later.

This integration retrieves users and devices, with group memberships from Microsoft Entra ID(formerly Azure Active Directory).

This module has been tested against the Microsoft Graph REST API v1.0.

The Microsoft Entra ID Entity Analytics integration collects two types of data: user and device. While configuring the integration, you can use the Dataset dropdown option to select which type of data you want to collect from Microsoft Entra ID.

Elastic Agent must be installed for standard deployments. For more details, check the Elastic Agent installation instructions.

Elastic Managed integrations are only supported on Elastic Cloud Serverless and Elastic Cloud Hosted deployments. An Elastic Managed integration lets you ingest data from a cloud source while avoiding the orchestration, management, and maintenance associated with standard ingest infrastructure. Elastic runs the collector for you, so you can focus on your data instead of the infrastructure that collects it. This functionality is in beta and is subject to change. Beta features are not subject to the support SLA of official GA features.

For more information, refer to Elastic Managed integrations and the Elastic Managed integrations FAQ.

The Microsoft Graph API is a public HTTPS endpoint, so no special connectivity configuration is required.

When using an Elastic Managed integration, the request tracer option is not available because it writes to the agent's local filesystem.

The following Azure API permissions are required:

Permission Type
GroupMember.Read.All Application
User.Read.All Application
Device.Read.All Application

If you want to collect device properties that are managed by Microsoft Intune, the following additional permission is required:

Permission Type
DeviceManagementManagedDevices.Read.All Application

Without this permission, the following device fields will return null values even if the devices are enrolled in Intune:

  • entityanalytics_entra_id.device.is_compliant
  • entityanalytics_entra_id.device.is_managed
  • entityanalytics_entra_id.device.compliance_expiration_date_time
  • entityanalytics_entra_id.device.category
  • entityanalytics_entra_id.device.ownership
  • entityanalytics_entra_id.device.enrollment_profile_name
  • entityanalytics_entra_id.device.mdm_app_id
Note

An active Microsoft Intune license is also required for the tenant for these properties to be populated.

To collect these fields, enable the Intune Managed Device Properties toggle in the integration settings. When enabled, the integration requests the additional fields from the Graph API automatically.

When the toggle is enabled, do not set select.devices in Custom Options as the two settings will conflict. Other Custom Options settings are unaffected. Users who need a fully custom device field list should use Custom Options directly with the toggle disabled.

For more details on how to set up the necessary App Registration, permission granting, and secret configuration, refer to this guide.

  1. In Kibana navigate to Management > Integrations.
  2. In the search bar, type Microsoft Entra ID Entity Analytics.
  3. Select the Microsoft Entra ID Entity Analytics integration and add it.
  4. While adding the integration, add the Tenant ID, Client (Application) ID and Secret (API Key) that you obtained earlier.
  5. Save the integration.

The integration periodically contacts Microsoft Entra ID using the Graph API, retrieving updates for users, devices, and groups, updates its internal cache of metadata and group membership information, and ships updated records to Elasticsearch.

Fetching and shipping updates occurs in one of two processes: full synchronizations and incremental updates. Full synchronizations send the entire list of users and devices in state. Incremental updates send only records that changed since the last sync. Changes include metadata updates, additions, deletions, and group membership changes (direct or transitive). By default, full synchronizations occur every 24 hours and incremental updates occur every 15 minutes. These intervals may be customized to suit your use case.

By default this integration uses minimal-state sync, which routes user and device documents directly to the user and device data streams. Existing policies are updated to use minimal-state sync on upgrade. Minimal-state sync and the User Sign-in Activity enrichment require Elastic Agent 9.5.0 or later; older agents use the legacy sync without sign-in activity.

This integration provides an asset inventory, a point-in-time snapshot of which users and devices exist and their current properties. It does not provide an audit trail of who changed what, or when. If you need to track administrative changes to Entra ID objects (user modifications, deletions, group membership changes by an administrator, etc.), use the Azure integration's audit logs data stream, which collects Entra ID audit logs via Event Hub.

A user document:

JSON
{
  "@timestamp": "2022-11-04T09:57:19.786056-05:00",
  "azure_ad": {
    "userPrincipalName": "example.user@example.com",
    "mail": "example.user@example.com",
    "displayName": "Example User",
    "givenName": "Example",
    "surname": "User",
    "jobTitle": "Software Engineer",
    "mobilePhone": "123-555-1000",
    "businessPhones": [
      "123-555-0122"
    ]
  },
  "user": {
    "id": "5ebc6a0f-05b7-4f42-9c8a-682bbc75d0fc",
    "group": [
      {
        "id": "331676df-b8fd-4492-82ed-02b927f8dd80",
        "name": "group1"
      },
      {
        "id": "d140978f-d641-4f01-802f-4ecc1acf8935",
        "name": "group2"
      }
    ]
  },
  "labels": {
    "identity_source": "azure-1"
  }
}

A device document:

JSON
{
  "@timestamp": "2022-11-04T09:57:19.786056-05:00",
  "azure_ad": {
    "accountEnabled": true,
    "displayName": "DESKTOP-LETW452G",
    "operatingSystem": "Windows",
    "operatingSystemVersion": "10.0.19043.1337",
    "physicalIds": {
      "extensionAttributes": {
        "extensionAttribute1": "BYOD-Device"
      }
    },
    "alternativeSecurityIds": [
      {
        "type": 2,
        "identityProvider": null,
        "key": "DGFSGHSGGTH345A...35DSFH0A"
      }
    ]
  },
  "device": {
    "id": "2fbbb8f9-ff67-4a21-b867-a344d18a4198",
    "group": [
      {
        "id": "331676df-b8fd-4492-82ed-02b927f8dd80",
        "name": "group1"
      }
    ]
  },
  "labels": {
    "identity_source": "azure-1"
  }
}

This is the Entity dataset.

Example
JSON
{
    "@timestamp": "2026-07-29T09:35:46.444Z",
    "agent": {
        "ephemeral_id": "ba88dec0-f6de-48e7-9946-8719b6f0cd06",
        "id": "a08acbcd-2d58-4e0f-b909-c2e369278788",
        "name": "elastic-agent-96580",
        "type": "filebeat",
        "version": "9.4.4"
    },
    "data_stream": {
        "dataset": "entityanalytics_entra_id.entity",
        "namespace": "93376",
        "type": "logs"
    },
    "ecs": {
        "version": "8.11.0"
    },
    "elastic_agent": {
        "id": "a08acbcd-2d58-4e0f-b909-c2e369278788",
        "snapshot": false,
        "version": "9.4.4"
    },
    "event": {
        "action": "started",
        "agent_id_status": "verified",
        "dataset": "entityanalytics_entra_id.entity",
        "ingested": "2026-07-29T09:35:49Z",
        "kind": "asset",
        "module": "entityanalytics_entra_id",
        "original": "{\"input\":{\"type\":\"entity-analytics\"},\"agent\":{\"name\":\"elastic-agent-96580\",\"id\":\"a08acbcd-2d58-4e0f-b909-c2e369278788\",\"type\":\"filebeat\",\"ephemeral_id\":\"ba88dec0-f6de-48e7-9946-8719b6f0cd06\",\"version\":\"9.4.4\"},\"@timestamp\":\"2026-07-29T09:35:46.444Z\",\"ecs\":{\"version\":\"8.11.0\"},\"data_stream\":{\"namespace\":\"93376\",\"type\":\"logs\",\"dataset\":\"entityanalytics_entra_id.entity\"},\"elastic_agent\":{\"id\":\"a08acbcd-2d58-4e0f-b909-c2e369278788\",\"version\":\"9.4.4\",\"snapshot\":false},\"event\":{\"start\":\"2026-07-29T09:35:46.444Z\",\"action\":\"started\",\"dataset\":\"entityanalytics_entra_id.entity\"},\"labels\":{\"identity_source\":\"entity-analytics-entityanalytics_entra_id.entity-c223753b-856d-4a4c-94e8-68670d6b3985\"},\"tags\":[\"all-entities\",\"preserve_original_event\",\"forwarded\",\"entityanalytics_entra_id-entity\"],\"_version_type\":\"internal\",\"_index\":\"logs-entityanalytics_entra_id.entity-93376\",\"_id\":null,\"_version\":-4}",
        "provider": "Microsoft Entra ID",
        "start": "2026-07-29T09:35:46.444Z"
    },
    "input": {
        "type": "entity-analytics"
    },
    "labels": {
        "identity_source": "entity-analytics-entityanalytics_entra_id.entity-c223753b-856d-4a4c-94e8-68670d6b3985"
    },
    "tags": [
        "all-entities",
        "preserve_original_event",
        "forwarded",
        "entityanalytics_entra_id-entity"
    ]
}
Exported fields
Field Description Type
@timestamp Event timestamp. date
asset.category keyword
asset.first_seen date
asset.group.id keyword
asset.group.name keyword
asset.id keyword
asset.is_managed boolean
asset.last_seen date
asset.last_updated date
asset.model keyword
asset.name keyword
asset.status keyword
asset.tags keyword
asset.type keyword
asset.vendor keyword
asset.version keyword
data_stream.dataset Data stream dataset. constant_keyword
data_stream.namespace Data stream namespace. constant_keyword
data_stream.type Data stream type. constant_keyword
device.group.id keyword
device.group.name keyword
device.registered_owners.business_phones keyword
device.registered_owners.display_name keyword
device.registered_owners.given_name keyword
device.registered_owners.id keyword
device.registered_owners.job_title keyword
device.registered_owners.mail keyword
device.registered_owners.mobile_phone keyword
device.registered_owners.surname keyword
device.registered_owners.user_principal_name keyword
device.registered_users.business_phones keyword
device.registered_users.display_name keyword
device.registered_users.given_name keyword
device.registered_users.id keyword
device.registered_users.job_title keyword
device.registered_users.mail keyword
device.registered_users.mobile_phone keyword
device.registered_users.surname keyword
device.registered_users.user_principal_name keyword
entityanalytics_entra_id.device.account_enabled true if the account is enabled; otherwise, false. Default is true. boolean
entityanalytics_entra_id.device.alternative_security_ids.identity_provider For internal use only. keyword
entityanalytics_entra_id.device.alternative_security_ids.key For internal use only. keyword
entityanalytics_entra_id.device.alternative_security_ids.type For internal use only. long
entityanalytics_entra_id.device.approximate_last_sign_in_date_time The timestamp type represents date and time information using ISO 8601 format and is always in UTC time. For example, midnight UTC on Jan 1, 2014 is 2014-01-01T00:00:00Z. date
entityanalytics_entra_id.device.category User-defined property set by Intune to automatically add devices to groups and simplify managing devices. keyword
entityanalytics_entra_id.device.compliance_expiration_date_time The timestamp when the device is no longer deemed compliant. The timestamp type represents date and time information using ISO 8601 format and is always in UTC time. For example, midnight UTC on Jan 1, 2014 is 2014-01-01T00:00:00Z. date
entityanalytics_entra_id.device.d_id Unique identifier set by Azure Device Registration Service at the time of registration. This is an alternate key that can be used to reference the device object. keyword
entityanalytics_entra_id.device.display_name The display name for the device. keyword
entityanalytics_entra_id.device.enrollment_profile_name Enrollment profile applied to the device. For example, Apple Device Enrollment Profile, Device enrollment - Corporate device identifiers, or Windows Autopilot profile name. This property is set by Intune. keyword
entityanalytics_entra_id.device.extension_attributes Contains extension attributes 1-15 for the device. The individual extension attributes are not selectable. These properties are mastered in cloud and can be set during creation or update of a device object in Azure AD. object
entityanalytics_entra_id.device.group.id The unique identifier for the group. keyword
entityanalytics_entra_id.device.group.name The display name for the group. keyword
entityanalytics_entra_id.device.id The unique identifier for the device. Inherited from directoryObject. keyword
entityanalytics_entra_id.device.is_compliant true if the device complies with Mobile Device Management (MDM) policies; otherwise, false. This can only be updated by Intune for any device OS type or by an approved MDM app for Windows OS devices. boolean
entityanalytics_entra_id.device.is_managed true if the device is managed by a Mobile Device Management (MDM) app; otherwise, false. This can only be updated by Intune for any device OS type or by an approved MDM app for Windows OS devices. boolean
entityanalytics_entra_id.device.manufacturer Manufacturer of the device. keyword
entityanalytics_entra_id.device.mdm_app_id Application identifier used to register device into MDM. keyword
entityanalytics_entra_id.device.metadata For internal use only. keyword
entityanalytics_entra_id.device.model Model of the device. keyword
entityanalytics_entra_id.device.on_premises_last_sync_date_time The last time at which the object was synced with the on-premises directory. The Timestamp type represents date and time information using ISO 8601 format and is always in UTC time. For example, midnight UTC on Jan 1, 2014 is 2014-01-01T00:00:00Z. date
entityanalytics_entra_id.device.on_premises_sync_enabled true if this object is synced from an on-premises directory; false if this object was originally synced from an on-premises directory but is no longer synced; null if this object has never been synced from an on-premises directory (default). boolean
entityanalytics_entra_id.device.operating_system The type of operating system on the device. keyword
entityanalytics_entra_id.device.operating_system_version The version of the operating system on the device. keyword
entityanalytics_entra_id.device.ownership Ownership of the device. This property is set by Intune. Possible values are: unknown, company, personal. keyword
entityanalytics_entra_id.device.physical_ids For internal use only. keyword
entityanalytics_entra_id.device.profile_type The profile type of the device. Possible values: RegisteredDevice (default), SecureVM, Printer, Shared, IoT. keyword
entityanalytics_entra_id.device.registered_owners.business_phones keyword
entityanalytics_entra_id.device.registered_owners.display_name keyword
entityanalytics_entra_id.device.registered_owners.given_name keyword
entityanalytics_entra_id.device.registered_owners.id keyword
entityanalytics_entra_id.device.registered_owners.job_title keyword
entityanalytics_entra_id.device.registered_owners.mail keyword
entityanalytics_entra_id.device.registered_owners.mobile_phone keyword
entityanalytics_entra_id.device.registered_owners.surname keyword
entityanalytics_entra_id.device.registered_owners.user_principal_name keyword
entityanalytics_entra_id.device.registered_users.business_phones keyword
entityanalytics_entra_id.device.registered_users.display_name keyword
entityanalytics_entra_id.device.registered_users.given_name keyword
entityanalytics_entra_id.device.registered_users.id keyword
entityanalytics_entra_id.device.registered_users.job_title keyword
entityanalytics_entra_id.device.registered_users.mail keyword
entityanalytics_entra_id.device.registered_users.mobile_phone keyword
entityanalytics_entra_id.device.registered_users.surname keyword
entityanalytics_entra_id.device.registered_users.user_principal_name keyword
entityanalytics_entra_id.device.registration_date_time Date and time of when the device was registered. The timestamp type represents date and time information using ISO 8601 format and is always in UTC time. For example, midnight UTC on Jan 1, 2014 is 2014-01-01T00:00:00Z. date
entityanalytics_entra_id.device.system_labels List of labels applied to the device by the system. keyword
entityanalytics_entra_id.device.trust_type Type of trust for the joined device. Read-only. Possible values: Workplace (indicates bring your own personal devices), AzureAd (Cloud only joined devices), ServerAd (on-premises domain joined devices joined to Azure AD). keyword
entityanalytics_entra_id.device.version For internal use only. keyword
entityanalytics_entra_id.user.account_enabled true if the account is enabled; otherwise, false. boolean
entityanalytics_entra_id.user.app_role_assignments.app_role_display_name The display name of the app role granted to the user. keyword
entityanalytics_entra_id.user.app_role_assignments.app_role_id The id of the app role assigned to the principal. keyword
entityanalytics_entra_id.user.app_role_assignments.created_date_time The time when the app role assignment was created. date
entityanalytics_entra_id.user.app_role_assignments.id A unique identifier for the appRoleAssignment key. keyword
entityanalytics_entra_id.user.app_role_assignments.principal_display_name The display name of the user that was granted the app role assignment. keyword
entityanalytics_entra_id.user.app_role_assignments.principal_id The unique identifier of the user that was granted the app role. keyword
entityanalytics_entra_id.user.app_role_assignments.resource_display_name The display name of the resource application to which the assignment was made. keyword
entityanalytics_entra_id.user.app_role_assignments.resource_id The unique identifier of the resource application to which the assignment was made. keyword
entityanalytics_entra_id.user.business_phones The telephone numbers for the user. keyword
entityanalytics_entra_id.user.department The name of the department in which the user works. keyword
entityanalytics_entra_id.user.direct_reports.display_name The display name of the direct report. keyword
entityanalytics_entra_id.user.direct_reports.id The unique identifier of the direct report. keyword
entityanalytics_entra_id.user.direct_reports.mail The SMTP address of the direct report. keyword
entityanalytics_entra_id.user.direct_reports.user_principal_name The user principal name of the direct report. keyword
entityanalytics_entra_id.user.display_name The name displayed in the address book for the user. This is usually the combination of the user's first name, middle initial and last name. keyword
entityanalytics_entra_id.user.given_name The given name (first name) of the user. Maximum length is 64 characters. keyword
entityanalytics_entra_id.user.group.id The unique identifier for the group. keyword
entityanalytics_entra_id.user.group.name The display name for the group. keyword
entityanalytics_entra_id.user.id The unique identifier for the user. Should be treated as an opaque identifier. Inherited from directoryObject. keyword
entityanalytics_entra_id.user.job_title The user's job title. Maximum length is 128 characters. keyword
entityanalytics_entra_id.user.mail The SMTP address for the user. keyword
entityanalytics_entra_id.user.manager.display_name The display name of the manager. keyword
entityanalytics_entra_id.user.manager.id The unique identifier for the manager. keyword
entityanalytics_entra_id.user.manager.mail The SMTP address of the manager. keyword
entityanalytics_entra_id.user.manager.user_principal_name The user principal name of the manager. keyword
entityanalytics_entra_id.user.mfa.is_mfa_capable Whether the user is capable of MFA. boolean
entityanalytics_entra_id.user.mfa.is_mfa_registered Whether the user has registered for MFA. boolean
entityanalytics_entra_id.user.mfa.is_passwordless_capable Whether the user is capable of passwordless authentication. boolean
entityanalytics_entra_id.user.mfa.is_sspr_capable Whether the user is capable of self-service password reset. boolean
entityanalytics_entra_id.user.mfa.is_sspr_enabled Whether the user has self-service password reset enabled. boolean
entityanalytics_entra_id.user.mfa.is_sspr_registered Whether the user has registered for self-service password reset. boolean
entityanalytics_entra_id.user.mfa.is_system_preferred_authentication_method_enabled Whether the system preferred authentication method is enabled for the user. boolean
entityanalytics_entra_id.user.mfa.methods_registered Collection of authentication methods registered by the user. keyword
entityanalytics_entra_id.user.mfa.system_preferred_authentication_methods Collection of authentication methods that the system determined to be the most secure for the user. keyword
entityanalytics_entra_id.user.mfa.user_preferred_method_for_secondary_authentication The method the user selected as the default second-factor for performing multi-factor authentication. keyword
entityanalytics_entra_id.user.mfa.user_type Identifies whether the user is a member or guest in the tenant. keyword
entityanalytics_entra_id.user.mobile_phone The primary cellular telephone number for the user. Read-only for users synced from on-premises directory. Maximum length is 64 characters. keyword
entityanalytics_entra_id.user.office_location The office location in the user's place of business. keyword
entityanalytics_entra_id.user.preferred_language The preferred language for the user. Should follow ISO 639-1 Code; for example en-US. keyword
entityanalytics_entra_id.user.sign_in_activity.last_non_interactive_sign_in_date_time The last non-interactive sign-in date and time. date
entityanalytics_entra_id.user.sign_in_activity.last_sign_in_date_time The last sign-in date and time. date
entityanalytics_entra_id.user.surname The user's surname (family name or last name). Maximum length is 64 characters. keyword
entityanalytics_entra_id.user.user_principal_name The user principal name (UPN) of the user. The UPN is an Internet-style login name for the user based on the Internet standard RFC 822. By convention, this should map to the user's email name. The general format is alias@domain, where domain must be present in the tenant's collection of verified domains. keyword
event.dataset Name of the dataset. constant_keyword
event.message Log message optimized for viewing in a log viewer. text
event.module Name of the module this data is coming from. constant_keyword
event.provider The event kind. constant_keyword
host.entity.attributes.managed Indicates whether the entity is managed by an external administration or control system. Typically applicable to Host and Service entities. boolean
host.entity.lifecycle.last_activity Timestamp of the most recent action performed by or attributed to this entity (active use). Distinct from entity.last_seen_timestamp, which records when the entity was last observed in data; last_activity implies the entity was active, not only seen. Typically applicable to User, Host, and Service entities. date
input.type Type of Filebeat input. keyword
labels.identity_source keyword
log.flags Flags for the log file. keyword
log.offset Offset of the entry in the log file. long
user.enabled boolean
user.entity.attributes.mfa_enabled Indicates whether multi-factor authentication is enabled for this entity. Typically applicable to User entities. boolean
user.entity.attributes.permissions Action-level permissions associated with this entity (not roles or groups). Typically applicable to User, Host, and Service entities. keyword
user.entity.lifecycle.last_activity Timestamp of the most recent action performed by or attributed to this entity (active use). Distinct from entity.last_seen_timestamp, which records when the entity was last observed in data; last_activity implies the entity was active, not only seen. Typically applicable to User, Host, and Service entities. date
user.entity.relationships.supervises.user.email Referenced user email addresses. keyword
user.entity.relationships.supervises.user.id Referenced user ids. keyword
user.entity.relationships.supervises.user.name Referenced user short names or logins. keyword
user.first_name keyword
user.group.id keyword
user.group.name keyword
user.job_title keyword
user.last_name keyword
user.phone keyword
user.work.location_name keyword
Changelog
Version Details Minimum Kibana version
1.15.1 Bug fix (View pull request)
Remove the package-level conditions.agent.version condition, which made Fleet silently drop this integration's inputs from agents older than the condition. Minimal-state sync (use_minimal_state) and the sign_in_activity enrichment are now gated in the input template on Elastic Agent 9.5.0 or later; older agents use the legacy sync without sign-in activity.
9.5.0
1.15.0 Enhancement (View pull request)
Update Elastic Managed integration documentation to the current wording and docs links.
9.5.0
1.14.0 Enhancement (View pull request)
Add tags to ingest pipeline processors.
9.5.0
1.13.0 Enhancement (View pull request)
Add agentless deployment mode and minimal-state sync support. Existing policies switch to the minimal-state sync implementation on upgrade.
9.5.0
1.12.0 Enhancement (View pull request)
Re-add the User Sign-in Activity toggle to collect sign-in activity data for Entra ID users.
9.4.4
1.11.0 Enhancement (View pull request)
Add the Advanced Analytics (UEBA) subcategory
9.4.0
1.10.2 Enhancement (View pull request)
Include approximateLastSignInDateTime in the device selection when Intune Managed Device Properties is enabled.

Bug fix (View pull request)
Remove non-functional User Sign-in Activity option (the signInActivity property is not available via the delta query endpoint and requires a dedicated enrichment path not yet implemented in the agent).
9.4.0
1.10.1 Bug fix (View pull request)
Remove misleading event.action values from sample events in documentation and clarify that this integration provides asset inventory, not an audit trail.
9.4.0
1.10.0 Enhancement (View pull request)
Add support for ECS entity fields.
9.4.0
1.9.1 Bug fix (View pull request)
Fix request tracer path in input configuration by including the input name in the path.
9.0.0
8.15.1
1.9.0 Enhancement (View pull request)
Add toggle for collecting Intune-managed device properties.
9.0.0
8.15.1
1.8.2 Bug fix (View pull request)
Fix documentation to include DeviceManagementManagedDevices.Read.All for some device fields.
9.0.0
8.15.1
1.8.1 Bug fix (View pull request)
Fix pipeline to ingest extra fields selected via select configuration in Custom Options.
9.0.0
8.15.1
1.8.0 Enhancement (View pull request)
Remove redundant installation instructions.
9.0.0
8.15.1
1.7.0 Enhancement (View pull request)
Add "event.original" field when "preserve_original_event" is set.
9.0.0
8.15.1
1.6.0 Enhancement (View pull request)
Update Kibana constraint to support 9.0.0.
9.0.0
8.15.1
1.5.1 Bug fix (View pull request)
Updated SSL description to be uniform and to include links to documentation.
8.15.1
1.5.0 Enhancement (View pull request)
Add "preserve_original_event" tag to documents with event.kind manually set to "pipeline_error".
8.15.1
1.4.0 Enhancement (View pull request)
Add "preserve_original_event" tag to documents with event.kind set to "pipeline_error".
8.15.1
1.3.1 Bug fix (View pull request)
Don't leak collection implementation details.
8.15.1
1.3.0 Enhancement (View pull request)
Add support for request trace logging.
8.15.1
1.2.0 Enhancement (View pull request)
Update the kibana constraint to ^8.13.0. Modified the field definitions to remove ECS fields made redundant by the ecs@mappings component template.
8.13.0
1.1.1 Bug fix (View pull request)
Fix broken link to Filebeat Entity Analytics input documentation.
8.12.0
1.1.0 Enhancement (View pull request)
Set sensitive values as secret.
8.12.0
1.0.1 Enhancement (View pull request)
Changed owners
8.11.0
1.0.0 Enhancement (View pull request)
Release package as GA.
8.11.0
0.6.1 Enhancement (View pull request)
Update Kibana version to 8.11.0.
8.11.0
0.6.0 Enhancement (View pull request)
ECS version updated to 8.11.0.
8.11.0
0.5.0 Enhancement (View pull request)
Add support for the device dataset and update user dataset to support preserve_duplicate_custom_fields option.
8.11.0
0.4.0 Enhancement (View pull request)
ECS version updated to 8.10.0.
8.9.0
0.3.0 Enhancement (View pull request)
The format_version in the package manifest changed from 2.11.0 to 3.0.0. Removed dotted YAML keys from package manifest. Added 'owner.type: elastic' to package manifest.
8.9.0
0.2.0 Enhancement (View pull request)
Add tags.yml file so that integration's dashboards and saved searches are tagged with "Security Solution" and displayed in the Security Solution UI.
8.9.0
0.1.0 Enhancement (View pull request)
Initial release of package.
8.9.0